Mobile App Data-Free connectivity
Resolved
Jun 14, 2026 at 9:18pm UTC
Data-Free connectivity has been restored. Employees can continue clocking normally.
Affected services
Updated
Jun 14, 2026 at 8:51pm UTC
Data-Free connectivity is recovering. Clocking remains available while we monitor stability.
Affected services
Updated
Jun 14, 2026 at 6:00pm UTC
No material change. Clocking remains available while Data-Free is temporarily bypassed.
Affected services
Updated
Jun 14, 2026 at 3:39pm UTC
We’re aware of an issue affecting Data-Free connectivity in the mobile app. We’ve temporarily bypassed Data-Free so employees can keep clocking in and out normally while we monitor restoration.
Affected services
Created
Jun 13, 2026 at 6:32pm UTC
We’re investigating an issue affecting Data-Free connectivity in the mobile app. Clocking remains available.
Affected services